Below Nav Bar Ad Module

Collapse

Announcement

Collapse
No announcement yet.

Replacing MMCS on NW Paj

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Replacing MMCS on NW Paj

    Hi all, I’ve finally had enough of the very (now) dated MMCS in my NW 2012 Paj. It’s near impossible to make phone calls with ease and the iPhone connectivity is useless for music now due to lightning connection. Has anyone recently upgraded to a new system that makes phone calls easier, connects Bluetooth for music, retains steering wheel controls and reverse camera, as well a navigation ..... is there a unit out there ??
    NW 2012 Pajero 'ACTIV' Auto Diesel
    Rear Diff Locker, 18" Toyo AT II, GME uhf radio, Tow-bar, Roof Racks, 2inch Lift (HD front, M rear), ARB Steel Bull bar, Boo's Bash Plates, Redarc Brake Controller
    https://www.pajeroforum.com.au/core/...ive%5B1%5D.gif

  • #2
    Originally posted by Rayzorback View Post
    Hi all, I’ve finally had enough of the very (now) dated MMCS in my NW 2012 Paj. It’s near impossible to make phone calls with ease and the iPhone connectivity is useless for music now due to lightning connection. Has anyone recently upgraded to a new system that makes phone calls easier, connects Bluetooth for music, retains steering wheel controls and reverse camera, as well a navigation ..... is there a unit out there ??

    Something I have been eyeing on when it gets stable enough -> https://www.youtube.com/watch?v=QIAnm1qCSio

    🅽🆇 🅿🅰🅹🅴🆁🅾

    Comment


    • #3
      Hmm, I would not be putting one of those in personally.
      All that touching and scrolling and lag etc. just to adjust the AC or heater etc.!

      Much better in my view to just put in a double-DIN CarPlay or Android Auto unit..
      Plenty of posts on here, just search the forum - I replaced mine but was base model stereo not MMCS but process should be quite similar.
      Steering wheel buttons are no issue to keep.
      Same for reverse camera - I kept the factory one too..
      2014 NW MY14 3.2 DID GLX-R Auto. Champagne in colour!
      MM Lockup mate. King KCRS-35 rear springs. Monroe Gas Magnum TDT rear shocks. 3M color stable tint all round. Spare wheel lift kit. 'Dynamat' in all doors and rear cargo area. Pioneer AVH-Z5150BT Head Unit. Upgraded Speakers. Rear (2nd row) USB outlet. Factory nudge bar with LED light bar. Provent catch can. LED interior lights. Rear cargo area twin Andersons and Merit socket. Anderson plug in rear bumper. 6 channel TPMS.

      Comment


      • #4
        I put an Alpine iLX-720D in my NX. Everything works fine, including the rear view camera and steering wheel controls. I didn't want navigation, the phone connected via Android auto or my android tablet can do that.

        IMG_20200415_163302.jpg IMG_20200415_170709[1].jpg IMG_20200415_163320.jpg
        2015 NX GLS, Factory alloy bar, Kings HD Springs & Koni Shocks with 50mm lift, MM Auto Mate, Paddle shift kit, dual batteries with Redarc DC/DC, LRA 58L tank, Safari snorkel, Boo's bash plates (full set), 17" steels with BFG KO2's, Drifta drawers with slide, TPMS, Uniden UH8080S, Alpine iLX-702D head unit.

        Comment


        • #5
          Hi Rayzorback

          Just setting out on this project myself in our 2013 NW VRX (no Rockford Fosgate)

          We just wanted to replace the awful MMCS with something functional - so opted for a cheap and cheerful Sony XAV-AX1000 - the idea being to just let apple carplay do everything.

          If you've got the same MMCS unit as us - it might help you to see what you'll find when you get the MMCS out - pictures attached.

          I'm still trying to figure out which harnesses I need to get everything to work.

          This page (https://pinoutguide.com/Car-Stereo-M...0_pinout.shtml) is helping make some sense of it.

          I have the Aerpro Sony to ISO (APP9SP4)
          The Aerpro SWC adapter suggests phone buttons on steering wheel wont work with Sony after markets - am looking at DNA Audio as a possible alternative.
          Yet to figure out an 8 pin adapter for the OEM camera

          Hope this is some help to you.


          You do not have permission to view this gallery.
          This gallery has 4 photos.

          Comment


          • #6
            I’m doing the same thing, got all the bits here apart from the Mito-02 Rockford amp adaptor which is coming from the USA. I’ve gone for a Kenwood DDX9020DABS head unit with Wireless Android Auto and Apple Car play. I’m changing the reverse camera as well to Kenwood unit. I expect it’s going to be a bit of a wiring mission though. Hopefully the adaptor arrives while I’m on my Xmas holidays and have the time to do it.

            I think in car Street Nav systems are obsolete these days, much better with google maps or Waze etc mirrored from your phone.
            2012 NW Activ with all the fruit, stripped what I could for my new build and handed over to the Mrs as a daily driver.

            Current vehicle: 2016 Y61 GU Patrol Legend series Auto, (Last of the Breed)
            3505kg GVM Upgrade and 2" Lift | Warn XD 9000 Winch | Factory steel bar, towbar, snorkel, alloy roof rack | 285/70/17 (33") Mickey T ATZ P3's | 3" Manta Exhaust | ORS Drawer System | Manual Boost Controller | ECU Remap |

            Comment


            • #7
              Originally posted by stevemc181 View Post
              I’m doing the same thing, got all the bits here apart from the Mito-02 Rockford amp adaptor which is coming from the USA. I’ve gone for a Kenwood DDX9020DABS head unit with Wireless Android Auto and Apple Car play. I’m changing the reverse camera as well to Kenwood unit. I expect it’s going to be a bit of a wiring mission though. Hopefully the adaptor arrives while I’m on my Xmas holidays and have the time to do it.

              I think in car Street Nav systems are obsolete these days, much better with google maps or Waze etc mirrored from your phone.
              I just bought the same Kenwood today, how is the progress going?

              Comment


              • #8
                Originally posted by Freddie1977 View Post

                I just bought the same Kenwood today, how is the progress going?
                I ended up getting a pro in to do the job a month or so ago. Wasn’t cheap but it’s all working well. I don’t drive the Paj often, but the missus seems happy with the new system. She did mention her S20 phone drops the wireless android auto connection occasionally, but I think that’s because she uses a wireless quadlock charger, and I suspect the phone gets too hot at times.
                2012 NW Activ with all the fruit, stripped what I could for my new build and handed over to the Mrs as a daily driver.

                Current vehicle: 2016 Y61 GU Patrol Legend series Auto, (Last of the Breed)
                3505kg GVM Upgrade and 2" Lift | Warn XD 9000 Winch | Factory steel bar, towbar, snorkel, alloy roof rack | 285/70/17 (33") Mickey T ATZ P3's | 3" Manta Exhaust | ORS Drawer System | Manual Boost Controller | ECU Remap |

                Comment


                • #9
                  Originally posted by &Roo View Post
                  Hi Rayzorback

                  Just setting out on this project myself in our 2013 NW VRX (no Rockford Fosgate)

                  We just wanted to replace the awful MMCS with something functional - so opted for a cheap and cheerful Sony XAV-AX1000 - the idea being to just let apple carplay do everything.

                  If you've got the same MMCS unit as us - it might help you to see what you'll find when you get the MMCS out - pictures attached.

                  I'm still trying to figure out which harnesses I need to get everything to work.

                  This page (https://pinoutguide.com/Car-Stereo-M...0_pinout.shtml) is helping make some sense of it.

                  I have the Aerpro Sony to ISO (APP9SP4)
                  The Aerpro SWC adapter suggests phone buttons on steering wheel wont work with Sony after markets - am looking at DNA Audio as a possible alternative.
                  Yet to figure out an 8 pin adapter for the OEM camera

                  Hope this is some help to you.

                  Since you mentioned a Sony unit, here is my update on installing a Sony XAV-AX1000 to replace the MMCS on my Paj, which has the Rockford Fosgate setup.
                  I have been able to retain steering wheel controls and even able to use voice based commands using it. Reverse camera has also been retained, and the new Head Unit allows for the guidelines to be displayed when reversing. Quite pleased with the new setup, which i managed to get all installed for less than $1000.

                  https://www.pajeroforum.com.au/forum...54#post1075054

                  Mitsubishi Pajero NT Platinum 2010

                  Comment


                  • #10
                    Originally posted by stevemc181 View Post

                    I ended up getting a pro in to do the job a month or so ago. Wasn’t cheap but it’s all working well. I don’t drive the Paj often, but the missus seems happy with the new system. She did mention her S20 phone drops the wireless android auto connection occasionally, but I think that’s because she uses a wireless quadlock charger, and I suspect the phone gets too hot at times.
                    I just got the unit delivered and I noticed that the cables provided by Kenwood are the ones for the Indonesia market, did you have that issue too, because those Indonesia cables are definitely not plug and play
                    You do not have permission to view this gallery.
                    This gallery has 1 photos.

                    Comment


                    • #11
                      Originally posted by Freddie1977 View Post

                      I just got the unit delivered and I noticed that the cables provided by Kenwood are the ones for the Indonesia market, did you have that issue too, because those Indonesia cables are definitely not plug and play
                      No idea what cables came with mine, as I let the installer do his thing. I don’t think any are plug and play with the premium Rockford system.
                      You’ll need at the least a Mito-02 adaptor and a CHMB2C and an APVMT01. There was splicing involved but I can’t tell you what or where it was spliced as I didn’t do the job. The whole job including the stereo/adaptors/install was nearly 2k, so not a cheap option.
                      2012 NW Activ with all the fruit, stripped what I could for my new build and handed over to the Mrs as a daily driver.

                      Current vehicle: 2016 Y61 GU Patrol Legend series Auto, (Last of the Breed)
                      3505kg GVM Upgrade and 2" Lift | Warn XD 9000 Winch | Factory steel bar, towbar, snorkel, alloy roof rack | 285/70/17 (33") Mickey T ATZ P3's | 3" Manta Exhaust | ORS Drawer System | Manual Boost Controller | ECU Remap |

                      Comment


                      • #12
                        Originally posted by stevemc181 View Post

                        No idea what cables came with mine, as I let the installer do his thing. I don’t think any are plug and play with the premium Rockford system.
                        You’ll need at the least a Mito-02 adaptor and a CHMB2C and an APVMT01. There was splicing involved but I can’t tell you what or where it was spliced as I didn’t do the job. The whole job including the stereo/adaptors/install was nearly 2k, so not a cheap option.
                        well installed the unit, all works fine, steering control, apple wireless etc. But one key item, there is no sound, I can see the radio and equalizer have sound. Anybody any idea?

                        Comment


                        • #13
                          Originally posted by Freddie1977 View Post

                          well installed the unit, all works fine, steering control, apple wireless etc. But one key item, there is no sound, I can see the radio and equalizer have sound. Anybody any idea?
                          Does your car have the Rockford amp setup? No sound means the amp is not getting powered. The CHMB4C harness i used explicitly mentions it triggers the amp.
                          Mitsubishi Pajero NT Platinum 2010

                          Comment


                          • #14
                            Originally posted by bennyb29 View Post

                            Does your car have the Rockford amp setup? No sound means the amp is not getting powered. The CHMB4C harness i used explicitly mentions it triggers the amp.
                            Yes it does, I went to JR Audio here in Melbourne and Jim helped me out, done in an hour and installed some other stuff too and for only 180 dollars, worth every penny. All good now with the new unit, only thing now is upgrading the speakers, because the head unit is way to powerful hahahah

                            Comment


                            • #15
                              Originally posted by Freddie1977 View Post

                              Yes it does, I went to JR Audio here in Melbourne and Jim helped me out, done in an hour and installed some other stuff too and for only 180 dollars, worth every penny. All good now with the new unit, only thing now is upgrading the speakers, because the head unit is way to powerful hahahah
                              Glad that it's sorted now. Totally agree that the upgrade is worth it.
                              Mitsubishi Pajero NT Platinum 2010

                              Comment

                              Matched content

                              Collapse
                              Working...
                              X