Below Nav Bar Ad Module

Collapse

Announcement

Collapse
No announcement yet.

Anti lock off light

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Anti lock off light

    Hi all, I have an NP 3.8 exceed. The other night driving down the freeway in a straight line the Anti lock off light came on, on the dash panel and the 2 other light next to it showing the little pic of a car skidding. I can't seem to get these 3 orange lights to go out. The car seems to drive the same , the switch has no effect, the fuse is ok. Does any one have any suggestions on what the problem could be, thanks in advance.

  • #2
    check your hbb canister....

    ie test your brakes..
    My Car is up for Sale => Link to Market Place

    Has a current Vic roadworthy (valid from the 28/04/2016)

    Comment


    • #3
      ABS Relay unplugged or faulty would cause that symptom
      2015 NX, ARB Bullbar, Bilstein / Lovells HD Front and Kings SP Rear, Polyairs, 17" NP Exceed wheels, D697 LT265/65/17, STEDI Cree 24" 120Watt light bar, Tracklander 2100 Roof Cage, Bushskinz side steps and bash plates, 200AH of Batts under rear floor via Redarc 40 Amp, cargo barrier with custom rear shelf up high, TC mod, EGR mod, catch can, iPhone4 with OBD app, USB ports in all 3 rows, custom storage in rear passenger guard.

      Comment


      • #4
        brakes seems to be working fine. I removed the relay and checked continuity with a meter and it seems to be working ok. I'm thinking I'll remove the panels and check that the switch is actually working, not sure where the other end of the wires go as I don't have a wiring diagram for this model. I've been trying to find a free one online but keep ending up on these Russian web sites that are full of adds, any other ideas???

        Thanks
        Kev

        Comment


        • #5
          Check if your rear brake lights are working, could be a blown brake light fuse.
          That causes those lights on the dash to come on. At least I think it is those, been a while since mine has done it. Can't remember which fuse it is but it is under the bonnet.

          Terry
          2005 NP GLX DiD,Alloy bullbar, Rallye 2000 driving lights, dual batteries,icomm UHF, 2" lift Ultimate Suspension, HD front,SD back with Ironman air bags, TJM underbody protection, HD valve body and Torque Converter, Engine Watchdog. In tow,Track Trailer T van.

          Comment


          • #6
            Thanks Terry, but they seem to be working fine.

            Kev

            Comment


            • #7
              more often than not, on here with those lights indicates the brake booster cannistor is failing its tests..
              My Car is up for Sale => Link to Market Place

              Has a current Vic roadworthy (valid from the 28/04/2016)

              Comment


              • #8
                Ok, so what's the best way to test the canister?

                Thanks
                kev

                Comment


                • #9
                  actually, simply check your manual first..

                  but if your handy with a spanner and pull the hbb off the car and apart to have a look..

                  otherwise i have no idea..
                  My Car is up for Sale => Link to Market Place

                  Has a current Vic roadworthy (valid from the 28/04/2016)

                  Comment


                  • #10
                    Problem solved ? the wife took it for a drive down some wet and slippery dirt roads and went through some deep puddles and the lights went out and have been out for a few days now, I wish they were all that easy.

                    Thanks everyone for your suggestions.

                    kev

                    Comment


                    • #11
                      Originally posted by kevinsavage View Post
                      Problem solved ? the wife took it for a drive down some wet and slippery dirt roads and went through some deep puddles and the lights went out and have been out for a few days now, I wish they were all that easy.

                      Thanks everyone for your suggestions.

                      kev
                      Seriously mate BE CAREFUL !!! This exact thing happened to me. Lights came on, then went out and all seemed ok for 6 or 7 days. Then it came back while driving on the freeway one afternoon. Seemed to drive normal though. Lights and loud alarm buzzer sound stayed on. Next morning Wife went to drive out of the driveway and no brakes. Pedal rock hard. If this happened on the road while driving at speed it would be very ugly.

                      Do yourself a favour and have a good mechanic hook up their laptop (with access to the HBB) and do a diagnostic. If it's like mine and many others on here, it will be the electric ABS/HBB pump. A guy did an awesome how to write up on how he had his fixed for around $350. Me on the other hand bought a new part, cost me $1300 including diagnostic, and installation. Don't assume it's ok because the lights went out. That's my advice.

                      Cheers
                      03 NP Exceed 3.5 V6 petrol auto, 2 inch Lovells / Bilstein lift, 15mm poly spacer in rear, 8mm alloy strut spacer in front (total 3" lift) 16x8 Ballistic Jester alloys 0 offset, 33" (285/75/16) Atturo Trail Blade M/T's, 2.5 exhaust with Advance extractors into high flow steel CAT and tri-flow muffler & resonator

                      Comment

                      Matched content

                      Collapse
                      Working...
                      X