Ad below navbar

Collapse

Announcement

Collapse
No announcement yet.

Battery Light

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Battery Light

    Hi Guys
    I started my 2008 NS Diesel today and the battery light stayed on and did so for about 10 kilometres. I checked the battery charge and it was 12.7 volts and dropped to about 10 volts when starting and then returned to 14.7-15 volts when running.
    I cleaned all of the terminals but the problem remains.
    Any ideas what this may be

    Thanks
    Michael
    2008 NS DID, Smart bar and warn winch, Boos Bash plates, ex nsw police car, Safair snorkel and 2 inch OME lift.

  • #2
    Hi, are the indicators still working, if not check and replace hazard lights fuse.

    Cheers Pete

    Comment


    • #3
      Hello Michael

      10 volts seems far to low when starting and as you have cleaned the terminals, I suspect your battery is on the way out and should be checked. If the battery checks OK, I would clean the battery earth connection(s) to the frame.

      I have a permanently installed voltmeter in My 2011 NT DID's cigarette lighter socket and also have the the original battery.

      Usual voltages I see are:
      12.7 volts after sitting overnight before starting.
      11.4 volts in the IGN position (due I think to the 30 amp load of the glow plugs) before staring,
      14.4 volts immediately after engine start for about a minute or so until the battery charge comes up, and then
      13.7 volts normal running.

      Regards

      Colin

      Comment


      • #4
        Hi Bigpete and XTV
        I have changed the fuse and this fixed my problem I will now look into my Battery.
        Thanks for your help.

        Michael
        2008 NS DID, Smart bar and warn winch, Boos Bash plates, ex nsw police car, Safair snorkel and 2 inch OME lift.

        Comment


        • #5
          Hi Michael, its a common fault easily fixed as you found, mine occasionally does the same volt meter sky rockets, first time MMA replaced altinater under warranty after that I changed fuse.

          Cheers

          Comment


          • #6
            Thanks guys - the same just happened to me.

            I noted the indicator lights and hazard lights not working. I had not checked the hazard lights initially so went looking for indicator light fuse.

            I wasn't sure where the fuse was so checked all of them (good idea any way) until I found the right one (dead).

            I was looking for fuse for indicators which I believed was in the fuse box under the dash - bloody hard to get to and see when you have glasses.

            They all were OK, so I checked the ones under the bonnet where I found a 10amp dud one.

            From what you say it was the hazard light one.

            RIch

            Comment


            • #7
              One to remember. Cheers.
              .Previously an NP GLX 3.8 auto RIP
              NS VRX DiD auto. RIP.

              Comment


              • #8
                HAd this twice now in about 3 and a half years. Last time it happened I replaced with a 15amp fuse cause that's all I had... Hasn't blown since, hopefully the 15 No drama...
                NT ACTIV 2010 DID Manual

                Comment


                • #9
                  Had this battery light fault happen to me today, really shows up as a bazaar fault i.e no Indicators or Hazard lights and the voltage regulator not working (battery charge = 15 V !!!) Thank goodness I remembered this post. The Hazard Fuse was definitely blown. All fixed now.
                  2007 NS SWB Pajero R DID, Rear Locker, BFG 265/70/17 T/A KO's, Towbar, B&D Bashplates, LRA AUX Fuel Tank, Lovells/Bilstein 50mm lift,
                  Dual Battery, ORS Fridge Pack 1,Fully Dynamatted, Bushskinz Sliders,ARB Deluxe Bar,Safari Snorkel, Chipit module, EGT Kit, DPF Delete, DPF SIM, Winch,Torque Converter Lockup, EGR fully sorted


                  2006 Landcruiser HDJ100

                  Comment


                  • #10
                    Had the battery light stay on happen today. Took a while to track down this post. Glad I remembered that it existed even if it took a while to track it down.

                    Yes my indicators are not working. That is easy to spot at night.

                    So will change the fuse tomorrow morning.
                    2007 NS R shortie, smartbar, Bushskinz intercooler & sump guard, Bridgestone AT Duelers


                    I try to take one day at a time, but sometimes several days attack me at once.

                    Comment


                    • #11
                      Took the old fuse out. It was fine. Replaced it with a new fuse.
                      Still get battery light fault and no hazard lights or indicator lights.

                      Any ideas please as to what is wrong?
                      2007 NS R shortie, smartbar, Bushskinz intercooler & sump guard, Bridgestone AT Duelers


                      I try to take one day at a time, but sometimes several days attack me at once.

                      Comment


                      • #12
                        Originally posted by jimnyjerry View Post
                        Took the old fuse out. It was fine. Replaced it with a new fuse.
                        Still get battery light fault and no hazard lights or indicator lights.

                        Any ideas please as to what is wrong?
                        This is where you go through and check each fuse.
                        2011 MY12 NW Pajero GL (White)

                        Factory Rear Diff lock | Modded Traction Control | Hankook RT03 MT LT265/70/17 | Uniden 7760nb UHF | Opposite Lock 3 Loop steel bar with fog lights |Runva EXW12000 | Bushskinz plates and sliders |Ultimate Suspension true 50mm Lift (above factory trim)

                        Wishlist:

                        Comment


                        • #13
                          Be sure to check the fuse with a test lamp or multimeter, not just by sight.

                          Are you sure it didn't just blow the replacement fuse also?
                          Pajero NX MY16 GLS

                          Comment


                          • #14
                            Thanks for the suggestions.
                            Will go now and test fuses with a multimeter. Back soon.
                            2007 NS R shortie, smartbar, Bushskinz intercooler & sump guard, Bridgestone AT Duelers


                            I try to take one day at a time, but sometimes several days attack me at once.

                            Comment


                            • #15
                              Replacement fuse tested and OK.

                              My Calcium battery indicates it needs charging but that should not effect the indicators.

                              Does the NS have a flasher unit for the indicators otherwise the problem may be with the indicator stalk?
                              2007 NS R shortie, smartbar, Bushskinz intercooler & sump guard, Bridgestone AT Duelers


                              I try to take one day at a time, but sometimes several days attack me at once.

                              Comment

                              Matched content

                              Collapse
                              Working...
                              X